2018年12月20日 星期四

change stm32_mmdvm_hs to usb mode work for bluedv



default you buy this rf board is gpio mode for raspberry,for now you can change to
usb mode for win7 /ubuntu work with blue dv or mmdvmhost +mmdvm .ini file

upgrade usb fw need raspberry and login in ssh mode in pi-star system
working for USB mode :

sudo service mmdvmhost stop
sudo pkill MMDVMHost
cd /tmp
sudo rm gpio.bin
sudo wget http://www.taozhengbo.com/usb.bin
sudo chmod 664 usb.bin
sleep 2
sudo pkill MMDVMHost
sudo pkill mmdvmhost.service
sudo stm32flash -v -w usb.bin -g 0x0 -R -i 20,-21,21:-20,21 /dev/ttyAMA0
echo "Rebooting Pi"
sleep 30
sudo reboot
working for GPIO mode :

sudo service mmdvmhost stop
sudo pkill MMDVMHost
cd /tmp
sudo rm gpio.bin
sudo wget http://www.taozhengbo.com/gpio.bin
sudo chmod 664 gpio.bin
sleep 2
sudo pkill MMDVMHost
sudo pkill mmdvmhost.service
sudo stm32flash -v -w gpio.bin -g 0x0 -R -i 20,-21,21:-20,21 /dev/ttyAMA0
echo "Rebooting Pi"
sleep 30
sudo reboot


2018年10月9日 星期二

MMDVM Main Board LAN To WAN wifi to AP Mode

default is ETH RJ45 is LAN Mode,Change it To WAN mode is More Stable ,ping is <10ms,wifi ping >20 ms.

wifi Change to AP Mode To Manage
Default SSID is MMDVM no passwork


nano /etc/config/network

---------------------------------------------
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd2e:2f55:5a3f::/48'

config interface 'lan'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.85.1'
option netmask '255.255.255.0'
option ip6assign '60'
option ifname 'radio0'

config device 'lan_dev'
option name 'eth0'
option macaddr '40:d6:3c:03:17:3b'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '0'

config interface 'wwan'
option proto 'dhcp'
option ifname 'eth0'

option hostname 'mmdvmwan'
-----------------------------------------------

nano /etc/config/wireless
------------------------------------------------

config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11g'
option path 'platform/10300000.wmac'
option country '00'
option legacy_rates '1'
option disabled '0'
option channel '7'
option htmode 'HT40'

config wifi-iface
option network 'lan'
option device 'radio0'
option mode 'ap'
option key '13902982913'
option wmm '0'
option ssid 'MMDVM'
option encryption 'none'

------------------------------------------
OPTION  Enable ACCESS WAN web config
nano /etc/config/firewall
--------------------------------------------
config zone
option name 'wan'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
option input 'ACCEPT'

option network 'wan wan6 wwan'


2018年9月13日 星期四

JumboSPOT Quick Start Setup List

1.Power your JumboSPOT wait 3-4 minutes
2.Connect JumboSPOT 's AutoAP wifi
3.Login and Set wifi Configure input your home ssid and pass
3.setting according List below

4.Set DMR Radio Channel and ID CC FREQ
5.Open Your need MODE P25/YSF/DSTAR/NXDN and set server

MMDVM Main Restore Default Update System File


if you click MMDVM mainboard restore
you need update system file or you can't find set Menu
first you must set wifi connect your home ssid



pi-star 3.4.16 mmdmv.ini file

[General]
Callsign=BGXXX
Id=4600555
Timeout=240
Duplex=0
RFModeHang=300
NetModeHang=300
Display=OLED
Daemon=1

[Info]
RXFrequency=439600000
TXFrequency=439600000
Power=1
Latitude=50.00
Longitude=-3.00
Height=0
Location="Town, L0C4T0R"
Description="Country"
URL=http://www.mw0mwz.co.uk/pi-star/

[Log]
DisplayLevel=0
FileLevel=2
FilePath=/var/log/pi-star
FileRoot=MMDVM

[CW Id]
Enable=0
Time=10

[DMR Id Lookup]
File=/usr/local/etc/DMRIds.dat
Time=24

[NXDN Id Lookup]
File=/usr/local/etc/NXDN.csv
Time=24

[Modem]
Port=/dev/ttyAMA0
TXInvert=1
RXInvert=0
PTTInvert=0
TXDelay=100
RXOffset=550
TXOffset=550
DMRDelay=0
RXLevel=50
TXLevel=50
RXDCOffset=0
TXDCOffset=0
RFLevel=100
CWIdTXLevel=50
D-StarTXLevel=50
DMRTXLevel=50
YSFTXLevel=50
P25TXLevel=50
NXDNTXLevel=50
POCSAGTXLevel=50
RSSIMappingFile=/usr/local/etc/RSSI.dat
Trace=0
Debug=0

[Transparent Data]
Enable=0
RemoteAddress=127.0.0.1
RemotePort=40094
LocalPort=40095

[UMP]
Enable=0
Port=/dev/ttyACM1

[D-Star]
Enable=1
Module=B
SelfOnly=1
AckReply=1
AckTime=750
ErrorReply=1
RemoteGateway=0
ModeHang=20

[DMR]
Enable=0
Beacons=0
BeaconInterval=60
BeaconDuration=3
ColorCode=1
SelfOnly=1
EmbeddedLCOnly=0
DumpTAData=1
CallHang=3
TXHang=4
ModeHang=20

[System Fusion]
Enable=1
LowDeviation=0
SelfOnly=1
TXHang=4
RemoteGateway=0
ModeHang=20

[P25]
Enable=0
NAC=293
SelfOnly=1
OverrideUIDCheck=0
RemoteGateway=0
ModeHang=20

[NXDN]
Enable=0
RAN=1
RemoteGateway=0
SelfOnly=1
ModeHang=20

[POCSAG]
Enable=0
Frequency=439987500

[D-Star Network]
Enable=1
GatewayAddress=127.0.0.1
GatewayPort=20010
LocalPort=20011
Debug=0
ModeHang=20

[DMR Network]
Enable=0
Address=87.117.229.173
Port=62031
Local=62032
Jitter=360
Password=passw1rd
Slot1=0
Slot2=1
Debug=0
ModeHang=20

[System Fusion Network]
Enable=1
LocalAddress=127.0.0.1
LocalPort=3200
GatewayAddress=127.0.0.1
GatewayPort=4200
Debug=0
ModeHang=20

[P25 Network]
Enable=0
GatewayAddress=127.0.0.1
GatewayPort=42020
LocalPort=32010
Debug=0
ModeHang=20

[NXDN Network]
Enable=0
LocalAddress=127.0.0.1
LocalPort=14021
GatewayAddress=127.0.0.1
GatewayPort=14020
Debug=0
ModeHang=20

[POCSAG Network]
Enable=0
LocalAddress=127.0.0.1
LocalPort=3800
GatewayAddress=127.0.0.1
GatewayPort=4800
ModeHang=5
Debug=0

[TFT Serial]
Port=/dev/ttyAMA0
Brightness=50

[HD44780]
Rows=2
Columns=16
Pins=11,10,0,1,2,3
I2CAddress=0x20
PWM=0
PWMPin=21
PWMBright=100
PWMDim=16
DisplayClock=1
UTC=0

[Nextion]
Port=/dev/ttyAMA0
Brightness=50
DisplayClock=1
UTC=0
ScreenLayout=0
IdleBrightness=20

[OLED]
Type=3
Brightness=0
Invert=0
Scroll=0

[LCDproc]
Address=localhost
Port=13666
DimOnIdle=0
DisplayClock=1
UTC=0

What is Auto AP and how do I use it? only support 3.4.16 and newer

Auto AP mode is designed to provide a setup wifi for you to connect to, if your Pi-Star device is not already on a network.

If Pi-Star does not detect a known wifi network within approximately the first 2 minutes of booting up, it will create its own wifi called Pistar-Setup. 

Using your computer/phone, you can then connect to the Pistar-Setup wifi. The password for this network is: raspberry

Once you have connected to the Pistar-Setup wifi, you will be able to pull up the dashboard. Make your wifi configuration changes. Save them, and reboot Pi-Star. It will not access the new network until you reboot.



how to update rtq hs hostpot duplex firmware from pi-star ssh


for RTQ STM32_DVM HS
sudo pistar-mmdvmhshatflash hs_hat

for DUPLEX_HS
sudo pistar-mmdvmhshatflash hs_dual_hat

2018年7月8日 星期日

JumboSpot Family




1.JS HS+Raspberry +16G TF
2.JS HS Duplex+2.2 TFT +Main board
3.JS HS Duplex+Main Board
4.JS MMDVM V2+Main Board

2018年6月20日 星期三

Connect new MMDVM Modem to GM300 Turn To DMR P25 YSF NXDN Digital Repeater or Hotspot






After Connect GM3xx ,GM950i is better,when power on,LED Flash fast,if your MD380 PTT Press,COS LED will ON,so,decode is ok,then you must SEE the BER using DEBUG Port,or in pi-star panel,ADJUST RX_R BER is <=2%,Then Test in Parrot you can hear your voice and PTT LED ON ,testing is Finished! It is Very Easy,I Testing Many Times.


FAQ:what MODE you Tested ? DMR or YSF or P25 I tested is the same.
FAQ:Does i need test Using MMDVMCal Program?If You Tested Fail,Best way Using MMDVMCal To Test GM3XX TX-> Mobile Function.
GM3XX RX-> Function It is Easy To Check Just COS(RECEIVE SIGNAL) LED And MODE LED,if Both LED ON ,GM3XX Rx is work!
FAQ:Does i need to change MMDVM.ini ->TX Invent and RX Invent ?that  is Also Import,in MMDVMCal TX Testing Mode you can Press I to Invent TX to Ensure Your GM3xx is invent or not .
TESTED:GM950i TX Invent =0,RX Invent=0

BEST for Test is GM338 and GM950i ,GM300 TX Freq is not stable ,rx is ok
GM300 need set inside Jumper to Disable 300HZ and 3000HZ filter.
GM950i need set RX AUDIO(FLAT(UNSQUELCHED)Accy Pin 11,and GP1 PTT LOW 3(I/P)  in GP I/O Lines


2018年6月19日 星期二

new VERSION MMDVM MODEM Released





FUTURE:
J2 For Raspberry or MMDVM Mainboard(more stable ,no tf card)
J1 ADD TTL (RX,TX,5V(in),PWR)
STM32F105RBT MCU
ADD NXDN LED
EASY UPGRADE,SHORT BOOT Jumper
Support raspberry 's OLED
Current Does not Support nextion TFT YET!(mmdvm Mainboard and raspberry )

2018年6月14日 星期四

How to Know which is Copy Of JumboSpot



Jumbospot is hot now,so some one copy on it ,left is copy one ,right is JumboSpot.

2018年6月8日 星期五

HOW TO USE MMDVM HOST WIF Main BOARD:


HOW TO USE MMDVM HOST WIF Main BOARD:
1. Connect your MMDVM HS/MMDVM HS DUPLEX/MMDVM Modem Board

2. Connect RJ45 to your PC and J1 For USB Power Cable,J3 is OTG ,D1  LED may light up.
3. Wait 30s Open http://192.168.85.1

4. If you install usb cp210x driver you can see the DEBUG Message USE AccessPort Terminal Software and BAUD 9600 is MMDVM Status MESSAGE,BAUD 57600 is system MESSAGE

5. Login MMDVM Panel USING root and pass 17234222
6. First Connect your Home wifi to enable WAN Function Click Network-> Wireless
Click SCAN and Select your home SSID Click JOIN NETWORK,Click Replace wireless configuration (important)

WAP passphrase input your home password,Click SUBMIT
7. Click UNSAVED CHANGES:10 ,Click SAVE & APPLY

MMDVM Host Main Board Connected your home wifi now,your Computer also Connect internet Now! PC  ping www.google.com to check.
8. Click System->RADIO_DMR_P25 Global 

Change 
MMDVM.ini Callsign=Replace your callsign,Id=Replace your DMR id, if you USE Duplex board Set Duplex=1
If you USE nextion TFT LCD,Set Dispaly=Nextion (current Don’t Support OLED)
If you Set DUPLEX=1 ,SET
 RXFrequency=451500000
TXFrequency=461500000
about 10MHZ+-
Next is Important
[Modem]
RXOffset=550
TXOffset=550
If you want DMR Mode Off Just SET
[DMR]
Enable=0
If you want P25 Mode Off Just SET
[P25]
Enable=0

Set DMR Server  Change 47.100.76.205 to Near you Server IP Find BMhosts.txt in Pi-star  
[DMR Network]
Enable=1
Address=47.100.76.205


All Done,In Service Click Restart Service

Check Status in Accessport

when you see  Host Running Ready QSO

You Can see Live Serial DEBUG MESSAGE:(AccessPort.exe)
D: 2018-06-08 08:10:12.243 DMR Slot 2, raw RSSI: 63, reported RSSI: 0 dBm
D: 2018-06-08 08:10:12.304 DMR Slot 2, raw RSSI: 63, reported RSSI: 0 dBm
D: 2018-06-08 08:10:12.305 DMR Slot 2, audio sequence no. 0, errs: 1/141 (0.7%)
D: 2018-06-08 08:10:12.363 DMR Slot 2, audio sequence no. 1, errs: 6/141 (4.3%)
D: 2018-06-08 08:10:12.425 DMR Slot 2, audio sequence no. 2, errs: 2/141 (1.4%)
D: 2018-06-08 08:10:12.483 DMR Slot 2, audio sequence no. 3, errs: 1/141 (0.7%)
D: 2018-06-08 08:10:12.544 DMR Slot 2, audio sequence no. 4, errs: 4/141 (2.8%)
D: 2018-06-08 08:10:12.603 DMR Slot 2, audio sequence no. 5, errs: 1/141 (0.7%)

BER <5% so RF WORK Great

E: 2018-06-08 08:12:10.112 Error returned from sendto, err: 128
E: 2018-06-08 08:12:10.112 DMR, Socket has failed when writing data to the master, retrying connection
M: 2018-06-08 08:12:10.112 DMR, Opening DMR Network
D: 2018-06-08 08:12:20.170 DMR, Sending authorisation
D: 2018-06-08 08:12:20.213 DMR, Sending configuration
M: 2018-06-08 08:12:20.250 DMR, Logged into the master successfully



Cp210x Driver:
Serial Live MESSAGE Monitor AccessPort

NEW MMDVM_HOST wifi BOARD replace raspberry zerow,b+,orange pi(no tf card ,very stable and fast)

1.Support 5V microusb Power input
2.
Support wifi client mode(connect home wifi)
3.Support MMDVM_HS,MMDVM_HS DUPLEX,MMDVM MODEM board
4. Cp210x Debug Serial out(9600bps)
5.Running MMDVMHost and P25Gateway(Current Only Support DMR and P25 Only)
6.Easy Configution MMDVM ini File in web  (no pi-star running)
7.Hardware
MIPS24KEc 580 MHz with 64 KB I-Cache and 32 KB D-Cache
128M DDR2 /32M Flash
1T1R 2.4 GHz with 150 Mbps PHY data rate
Legacy 802.11b/g and HT 802.11n modes
1-port 10/100 FE PHY











2018年6月5日 星期二

maple-serial usb driver



Find


X:\arduino-nightly\hardware\Arduino_STM32\drivers\win\win_xp_legacy\maple-serial \installer_x64.exe

2018年5月29日 星期二

how to upgrade MMDVM FW to new Version (Support NXDN)

https://drive.google.com/file/d/107O-Wf4-OAa1T1bfADaLST-Vsi6iVHuk/view?ths=true


How To Connect MMDVM BOARD to your GM300 GM338 GM950i
A:Using Software,Pi-star,stm32flash,MMDVMCal(come with pi-star)
B:Using Hardware,raspberry zero w or raspberry 2 B+,GM950i
Ps :Testing GM950i is very Stable then old GM300/GM338
1. hardware Connect









Current PTT+GND+RX+TX is Work

2. Using MMDVM Cal To Test if work!
Current MMDVM board have two version ,old fw don’t support NXDN,new fw support NXDN
If you want update




#stm32flash -w RPT_134.hex /dev/ttyS0



My router is ttyS0,raspberry zero w is ttyAMA0
Caution ,you Must Stop MMDVMHost frist when you Update FW.
When Done ,your fw is new now.

Next Testing Using MMDVMCal  you can see the MMDVM baord is 20180327 new version


If you test USING DMR MD380 pls write TG9 and save .

Then press m to testing DMR MS 1031 Test Pattern,and press Space,Start Transmit ,then ADJUST TX ,if you can hear 1khz sound in MD380( TG9,1)   your adjust is ok, stop ADJUST.
If not Press I ,Change  testing Transmit Inversion,and Try Again.


If DMR testing TX is ok,no need testing P25 Testing Pattern,if you like is better.

MMDVM BOARD Woking Condition:
Power :5V
When testing D-DMR Deviation Mode,you can see TP42 or TX pin is 1.2Khz
Wave in Scope,if TX testing is not good ,pls Try TX Inversion.
Final in pi-star ,is the same Tx Inversion =0 or 1



2018年3月26日 星期一

how to use mmdvm_hs_hat_duplex rf board for pi-star


EXAMPLE mmdvm.ini for duplex rf board #start line is disable
if you use mmdvmhost pls change mmdvm.ini

[General]
Callsign=your call sign
Id=you dmr id
Timeout=240
#setting for duplex rf board
Duplex=1
# ModeHang=10
RFModeHang=300
NetModeHang=300
#Display=Nextion
Daemon=0

[Info]
#DMR mobile tx freq
RXFrequency=451500000
#DMR mobile rx freq
TXFrequency=461500000
Power=1
Latitude=16.105564
Longitude=19.29946
Height=0
Location="NY,USA"
Description="USA"
URL=http://www.qrz.com/db/BG0DJJ

[Log]
# Logging levels, 0=No logging
DisplayLevel=1
FileLevel=0
FilePath=.
FileRoot=MMDVM

[CW Id]
#enable you will hear on analog mobile 461.500 mhz your call id every 10minutes
Enable=1
Time=10
# Callsign=

[DMR Id Lookup]
File=DMRIds.dat
Time=24

[Modem]
# Port=/dev/ttyACM0
Port=\\.\COM3
TXInvert=1
RXInvert=0
PTTInvert=0
TXDelay=100
#some board need set offset 500 both
RXOffset=500
TXOffset=500
DMRDelay=0
RXLevel=50
TXLevel=50
TXDCOffset=0
#CWIdTXLevel=50
#D-StarTXLevel=50
#DMRTXLevel=50
#YSFTXLevel=50
#P25TXLevel=50
RSSIMappingFile=RSSI.dat
Trace=0
Debug=0

[UMP]
Enable=0
# Port=\\.\COM4
Port=/dev/ttyACM1

[D-Star]
Enable=0
Module=B
SelfOnly=0
AckReply=1
AckTime=750
ErrorReply=1
# ModeHang=10

[DMR]
Enable=1
Beacons=0
ColorCode=1
SelfOnly=0
EmbeddedLCOnly=0
DumpTAData=1
# Prefixes=234,235
# Slot1TGWhiteList=
# Slot2TGWhiteList=
CallHang=3
TXHang=3
ModeHang=5

[System Fusion]
Enable=0
LowDeviation=0
SelfOnly=0
#DSQ=1
RemoteGateway=0
ModeHang=5

[P25]
Enable=0
NAC=293
SelfOnly=0
OverrideUIDCheck=0
# ModeHang=10

[D-Star Network]
Enable=0
GatewayAddress=127.0.0.1
GatewayPort=20010
LocalPort=20011
# ModeHang=3
Debug=0

[DMR Network]
Enable=1
Address=47.100.76.205
#bm.dv.or.kr 47.100.76.205
Port=62031
Jitter=300
# Local=62032
Password=passw0rd
# Options=
# Options=StartRef=46001;RelinkTime=15;UserLink=1;TS1_1=460;TS1_2=46600;TS1_3=3100;TS1_4=91;TS1_5=92;
Slot1=1
Slot2=1
ModeHang=5
Debug=0

[System Fusion Network]
Enable=0
LocalAddress=127.0.0.1
LocalPort=3200
GwyAddress=127.0.0.1
GwyPort=4200
ModeHang=5
Debug=0

[P25 Network]
Enable=0
GatewayAddress=127.0.0.1
GatewayPort=42020
LocalPort=32010
# ModeHang=3
Debug=0

[TFT Serial]
# Port=modem
Port=/dev/ttyAMA0
Brightness=50

[HD44780]
Rows=2
Columns=16

# For basic HD44780 displays (4-bit connection)
# rs, strb, d0, d1, d2, d3
Pins=11,10,0,1,2,3

# Device address for I2C
I2CAddress=0x20

# PWM backlight
PWM=0
PWMPin=21
PWMBright=100
PWMDim=16

DisplayClock=1
UTC=0

[Nextion]
Port=modem
# Port=/dev/ttyAMA0
#Port=\\.\COM5
Brightness=50
DisplayClock=1
UTC=0
IdleBrightness=10
ScreenLayout=3

[OLED]
Type=3
Brightness=0
Invert=0
Scroll=1

[LCDproc]
Address=localhost
Port=13666
#LocalPort=13667
DimOnIdle=0
DisplayClock=1
UTC=0
----------------------------------------------------------------------------------------

if you use pi-star pls set below


also set the rxtxoffset if need

MD380 new Channel for DUPLEX



2018年3月3日 星期六

mmdvm host for windows

if you have cp210x or ft232rl or pl2303 any other serial to usb you can test jumbospot for windows  instead raspberry








pls download

http://www.taozhengbo.com/MMDVM Host For Windows.zip

open and change MMDVM-H.ini 

[General]
Callsign=BH8XXX  #change to your callsign
Id=46080XX  #change to your dmr id


[Modem]
Port=\\.\COM3   # change to your cp2102 installed driver 's com port my is com3

run  DMR - 2.2.bat           is for nextion 2.2 tft hmi lcd

run  DMR.bat           is for dmr

run   P25.bat       is for P25


How To SET RXOFFSET or TXOFFSET



HOW TO SET RXOFFSET(TXOFFSET)

Change RXOFFSET and TXOFFSET to xxx(500 maybe ok) and click apply.

and test BER <=5% is OK.
---------------------------------------------------

setting offset for mmdvm host for windows